Support center
Subscribe to updates
Support center
Subscribe to updates
Powered by
Begin Monitoring
Resolved
·
Full outage
Begin monitoring for status page.
Mon, Aug 17, 2026, 07:20 PM
(
34
minutes ago)
·
View all updates
Affected components
Jan 1, 2026, 07:01 AM
07:02 AM
Website
Client Portal
1GServers Data Center PHX1
5 affected components
RadiusDC Data Center PHX1 (formerly Phoenix NAP)
5 affected components
Updates
Resolved
Begin monitoring for status page.
Mon, Aug 17, 2026, 07:20 PM
Resolved
Begin monitoring
Thu, Jan 1, 2026, 07:00 AM
(
7
months earlier)
Begin Monitoring - 1GServers Status